PDA

Vollständige Version anzeigen : diverse Probleme mit Farben bei Pflichtfragen, Antwortoption plus Text, Matrixfrage


nora.buchheit-schwarz
04.09.2012, 18:04
Hallo!

Ich habe verschiedene Layoutprobleme mit meinem Projekt. Leider konnten mir weder mit die Anleitung noch alte Forenbeiträge weiterhelfen. Ich hoffe nun sehr, dass mir hier geholfen werden kann.

(1) Wenn ich Fragen als Pflichtfragen kennzeichne, so ändert sich deren Erscheinungsbild: Die Schrift ist rot statt hellblau und am Ende der Frage wird ein Sternchen angezeigt. Ich möchte gerne, dass das Sternchen verschwindet und die Fragen einheitlich hellblau bleiben. Rot finde ich zudem kritisch, weil jemand mit rot-grün Sehschwäche die Farbe gar nicht erkennt. Meine Frage: wie kann ich die Schriftfarbe der Fragen ändern? U.a. Betroffen ist Seiten-ID: 1801631, 1801782, 1802827,…

(2) Ich möchte gerne eine Antwortoption anbieten die „Sonstiges:“ heißt und ein Textfeld in der gleichen Zeile anbietet. In der Anleitung liest sich das total einfach, man soll als Antwortoption „Antwortkategorie + Text“ auswählen und schon erhält man eine solche gemischte Antwort. Bei mir funktioniert das aber nicht. Es erscheint NIE ein Textfeld nach der Antwort. Als Antwortoption erscheint „Sonstiges“ – mehr nicht. Wenn ich „Sonstiges %s“ eingebe, um anzuzeigen wo das Textfeld hinsoll, erscheint ebenfalls „Sonstiges %s“ als Antwortoption. Wie kann ich diese Funktion nutzen? Ich verstehe nicht wo mein Fehler liegt, da ich mich an die Anleitung halte. Betroffen sind u.a. die Fragen der Seiten-ID: 1801631, 1801804, 1801803, 1802829, 1801575. Teilweise habe ich das Problem, das die Kategorie „Sonstiges“ nun sogar doppelt angezeigt wird: Betroffen sind die Fragen 3435442, 3438016, 3438100, 3438101
Ärgerlich ist außerdem, dass bei der Auswahl von „Antwortkategorie + Text“ diese Option nun mit anderen Antworten kombiniert werden kann. Obwohl es sich um eine Einfachauswahl (Fragetyp 111) handelt.

(3) In meinem Fragebogen befinden sich zwei Matrixfragen der Nummer 311, welche nicht immer im gleichen Layout erscheinen. Ich wünsche mir die Fragen links und die Skala rechts, so dass rechts neben jeder Frage eine Bewertung vorgenommen werden kann. Hin und wieder werden Fragen und Bewertung jedoch untereinander angeordnet. Wieso ist das nicht immer einheitlich? (Beim Benutzen des gleichen Browsers!) Betroffen sind die Fragen der Seiten-ID: 1801577, 1801579

(4) Bei einer Frage biete ich ein Textfeld an, welches ich gerne größer erscheinen lassen möchte. Hier habe ich unter Frageoptionen Einstellungen vorgenommen (Werte bei „Breite Textfeld“ und „Anzahl Zeilen“ geändert). Die Vorschau reagiert aber nicht auf meine Eingaben. Das Textfeld hat eine unverändert (kleine) Größe. Was muss ich machen, damit das Textfeld auf meine Eingaben reagiert? Betroffen ist die Seiten-ID: 1801630, 1802831

(5) Gibt es die Möglichkeit bei Mehrfachauswahl eine einzelne Antwort anzubieten (beispielsweise „Keine Angabe“) die nicht mit den anderen Optionen gleichzeitig ausgewählt werden kann? So dass man entweder eine oder mehrere beliebige Antworten auswählt oder eben diese Antwort, die sich mit den anderen ausschließt? In der Anleitung finde ich die von mir beschriebene Funktion unter „Exklusiv“ wieder. Leider funktioniert es in der Vorschau aber nicht. Betroffen ist Seiten-ID: 1802899

Ich freue mich sehr über Hilfe und stehe für Rückfragen gerne zur Verfügung!
Viele Grüße
Nora Buchheit-Schwarz

http://ww3.unipark.de
Projekt ID: 300355
Zugang: buchheit-schwarz

JensL
05.09.2012, 11:41
Hallo Nora,

Zu 1.:
Die Farbe der überschriften ist beim adaptiven Layout so gewollt und dient dazu, dem Teilnehmer im Fragebogen anzuzeigen welche Fragen DAC's sind.
Möchtest Du das ändern, so gehe bitte in den Layout Profi-Editor und öffne dort ganz unten die CSS Datei style.css
Hier suchst Du nach der Klasse

.question.required header h2 {
color: #b94a48;
}

und änderst den Farbcode dementsprechend.
Wenn Du die Farbe gleich wie bei den anderen Überschriften haben möchtest, wäre der richtige Farbcode hier #4e6a80.

Um den Stern zu entfernen lösche den Abschnitt


.question.required header h2:after {
content: ' *';
}

in der selben Datei.

zu 5)
Du musst einfach nur bei der entsprechenden Antwortoption einen Haken bei "eklusiv setzen.

Zu den restlichen Fragen melde ich mich wieder, ich muss da zunächst etwas abklären.

Gruß,
Jens

//edit:

Am besten gehst Du einfach mal unter Layout -> Layoutvorlagen -> Standardlayout-Einstellungen wiederherstellen
Dies setzt die Layouteinstellungen auf die Standardwerte zurück. Danach musst Du zwar Layout-bezogene Einstellungen erneut vornehmen, gleichzeitig würde es aber einen Großteil der von Dir genannten Probleme beseitigen und auch die o.g. Änderungen unnötig machen.

nora.buchheit-schwarz
05.09.2012, 16:40
Herzlichen Dank! Es funktioniert jetzt :-)

Mascha_Kirchner
02.11.2012, 08:41
Hallo,

ich stehe vor dem gleichen Problem und hab die Änderungen befolgt. Trotzdem erscheint das Layout noch in rot und mit * .... Woran könnte dies liegen?

84

85

Danke für die Hilfe!

Viele Grüße,
Mascha.

JensL
06.11.2012, 16:47
Hallo Mascha,

ich habe gerade in Deine Umfrage geschaut, also in der zweiten CSS steht:

.question header h2 {
color: #4e6a80;
}
.question.required header h2 {
color: #b94a48;
}
.question.required header h2:after {
content: ' *';
}


dementsprechend auch Stern und Farbe.

Ich habe mir das in der Umfrage aus Deinem anderen Beitrag angeschaut (PID 77702), sollte das die falsche sein, so poste doch bitte die Daten der richtigen.

Ich würde Dir auch empfehlen unter Layoutvorlagen die Standard-Vorlage auszuwählen, außer Du hast bereits exzessive Layou-Änderungen vorgenommen.

Gruß,
Jens

Mascha_Kirchner
14.11.2012, 16:44
Hallo Jens,

danke für deine Antwort. Ich hab jetzt Änderungen vorgenommen:

header h1 span {
color : #95a500 ;
}

.question header h2 {
margin-bottom : 0.1em ;
color : #4e6a80 ;
}

.question.required header h2 {
color : 4e6a80 ;
background-color : #DDDDDD ;
background-image : none ;
}

.question header p {
margin : 0 ;
padding : 0 ;
color : #5d5d5d ;
}


Leider erscheinen Pflichtfragen immer noch rot und mit Sternchen....

Die Projekt-ID ist: 77702

Hast du eine Idee woran das liegen kann? Das Standard-Layout habe ich übernommen. Nur das Bild ist von mir ausgetauscht worden.

Ansonsten habe ich den HTML-Code für das Sternchen gelöscht und die Schriftfarbe bei Pflichtfragen auf "blau" gestellt... Dies sieht man aber nicht.

Ich danke dir für deine Hilfe!

Viele Grüße,
Mascha.

JensL
15.11.2012, 14:25
Hallo Mascha,

also ich habe mich durch Deinen Fragebogen geklickt und konnte dabei keine Pflichtfragen entdecken, dementsprechend konnte ich auch keine Sterne sehen.

Außerdem hast Du nicht unter Layout -> Layoutvorlagen -> Standardlayout-Einstellungen das Layout zurückgesetzt, zumindest ist das in Deiner Umfrage immernoch das adaptive Layout.

Gruß,
Jens

Mascha_Kirchner
18.11.2012, 10:57
Hallo Jens,

danke für deine Antwort. Ich hatte die Pflichfragen-Option ausgeschaltet, weil das "rot" nicht wegegangen ist. Es betrifft das Projekt 77702. Auf Seite 1 habe ich die Fragen jetzt als Pflichtfragen markiert.

Das adpaptive Layout würde ich gerne verwenden, weil es mir von den Alternativen am Besten gefallen hat. Ist es möglich auch hier eine Veränderung bei der Darstellung der Pflichfragen vorzunehmen? Also das die Fragen nicht "rot" sind und nicht durch ein "*" gekennzeichnet sind....

Danke für deine Hilfe!

Viele Grüße,
Mascha.

JensL
26.11.2012, 12:04
Hallo Mascha,

in der style.css sind die Elemente auch immernoch drin:


.question header h2 {
color: #4e6a80;
}
.question.required header h2 {
color: #b94a48;
}
.question.required header h2:after {
content: ' *';


Gruß,
Jens